PTSD

posted in technology | 0 comments

Oh gods, but what a horrible flashback to my early Linux days and my nightmares of dependency hell. Package A would require package B. Package B would require package C. It was one of the things that drove me away from Linux during my first

The proliferation of Linux package managers – Portage, Aptitude, Pacman, and YUM – have raised us from those dreary dark days, but you can still run into it if you stray off the beaten path and install packages by hand.


[root][Downloads] # dpkg -i python-gtkhtml2_2.25.3-3ubuntu1.9.10.1_i386.deb
Selecting previously deselected package python-gtkhtml2.
(Reading database ... 144293 files and directories currently installed.)
Unpacking python-gtkhtml2 (from python-gtkhtml2_2.25.3-3ubuntu1.9.10.1_i386.deb) ...
dpkg: dependency problems prevent configuration of python-gtkhtml2:
python-gtkhtml2 depends on libgtkhtml2-0 (>= 2.11.1); however:
Package libgtkhtml2-0 is not installed.
dpkg: error processing python-gtkhtml2 (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
python-gtkhtml2

To explain the above for a lay reader: In order to install the program phython-gtkhtml2…I was required to have phython-gtkhtml2 already installed.

Argh.

by Mark on
Tagged: , , , , , , , , ,

Say something

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>